前兩三天等不及openoffice3中文版釋出,就自己灌了英文版外加rc4的語言套件
因為投影片都習慣打中文,所以很少切換輸入法,直到今天,事情就這麼發生了....

不能切,用鍵盤、用滑鼠,不能切就真的是不能切

以為是英文版加中文語言包問題,灌回rc4中文,還是不行切...
揪在這個摸門特...眼睛撇到了終端機的訊息...

(soffice:16606): Gtk-WARNING **: /opt/openoffice.org3/program/../basis-link/ure-link/lib/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /usr/lib/gtk-2.0/2.10.0/immodules/im-scim.so)

(soffice:16606): Gtk-WARNING **: Loading IM context type 'scim' failed

看起來是openoffice3用了自己的lib,但是版本不太對的樣子,管他的,有訊息就是google大神啦
為什麼台灣人都沒有出現這個訊息咧?/___\

總之,解決了
先把/opt/openoffice.org3/basis-link/ure-link/lib下的libgcc_s.so.1、libstdc++.so.6備份起來
接著把系統的兩個連結過來
sudo ln -s /usr/lib/libstdc++.so.6 libstdc++.so.6
sudo ln -s /lib/libgcc_s.so.1 libgcc_s.so.1

啟動看不到錯誤訊息了!也可以正常使用輸入法了!YES!!

koukaipan 發表在 痞客邦 PIXNET 留言(0) 人氣()